World Map
Java Service Wrapper is the easiest way to make your product more reliable.
  • Free Trial
  • Buy Now
Supported platforms (Wrapper version 3.5.*)

Index: Supported platforms (Wrapper version 3.5.*)

Overview

x86x64IA64PPCOthers

Not Applicable Not Applicable Not Applicable In-House Tested No

In-House Tested In-House Tested No No No

Not Applicable Not Applicable In-House Tested Not Applicable In-House Testedparisc

In-House Tested In-House Tested In-House Tested In-House Tested No

In-House Tested In-House Tested Not Applicable In-House Tested No

In-House Tested In-House Tested No No In-House Testedsparc

In-House Tested In-House Tested In-House Tested No No

Not Applicable Not Applicable Not Applicable Not Applicable In-House Tested390

Legend

  • In-House Tested

    In-house tested. Prior to each release, the Wrapper will be tested intensively to ensure functionality.

  • Usage reported

    Usage confirmed by users and partners.

  • Expected to run

    Compatible OS and APIs. Expected to run normally.

  • No

    Not supported

  • Not Applicable

    Not Applicable

Windows

x86x64IA64Remarks
Windows Server 2003 Usage reported Usage reported In-House Tested

The Wrapper for Windows Itanium is built and tested on Windows Server 2003 SP1.

In January 2016, Microsoft deprecated SHA1 certificates in favor of SHA2 certificates. To keep compatibility with the recent version of Windows and increase security, the Wrapper is now signed with a SHA2 certificate from version 3.5.28 onwards. This new certificate uses an algorithm that is not supported on this platform and will be ignored when running the Wrapper.

DEP and ASLR are not supported on this platform.

Windows XP (SP < 3) Usage reported Usage reported Usage reported

In January 2016, Microsoft deprecated SHA1 certificates in favor of SHA2 certificates. To keep compatibility with the recent version of Windows and increase security, the Wrapper is now signed with a SHA2 certificate from version 3.5.28 onwards. This new certificate uses an algorithm that is not supported by Windows XP without SP3 and will be ignored when running the Wrapper.

DEP and ASLR are not supported on this platform.

Windows XP SP3 In-House Tested Not Applicable Not Applicable ASLR is not supported on this platform. DEP is enabled.
Windows Vista Expected to run Expected to run Not Applicable

DEP and ASLR are enabled on this platform and all versions of Windows released after Windows Vista.

Known Issue: Due to a stricter security policy introduced in Windows Vista, services are running in a separate desktop. The same behavior applies to all versions of Windows released after Windows Vista.

Windows 7 Usage reported Usage reported Not Applicable Microsoft published an update to add support for SHA-2 on this platform. If this update is present you will be able to verify the Wrapper authenticity with the SHA-2 hash included in its binaries, else you will only be able to verify the SHA-1 hash.
Windows Server 2008 Usage reported Usage reported Usage reported
Windows Server 2008 R2 In-House Tested In-House Tested Usage reported

The current versions of the Wrapper for x86 architectures are built and tested on this platform.

Microsoft published an update to add support for SHA-2 on this platform. If this update is present you will be able to verify the Wrapper authenticity with the SHA-2 hash included in its binaries, else you will only be able to verify the SHA-1 hash.

Windows Server 2012 (& R2) Usage reported Usage reported Not Applicable The Wrapper authenticity can be verified with both SHA-1 and SHA-2 hashes on this platform and any version of Windows released after Windows Server 2012.
Windows 8/8.1 Usage reported Usage reported Not Applicable The Wrapper authenticity can be verified with both SHA-1 and SHA-2 hashes on this platform and any version of Windows released after Windows 8.
Windows 10 In-House Tested In-House Tested Not Applicable
Windows Server 2016 In-House Tested In-House Tested Not Applicable
Nano Server Not Applicable No Not Applicable Considering adding support for this platform. Please contact us if you are interested.

Linux

There are no known distribution specific restrictions on the Wrapper to run on a Linux based OS.

x86x64IA64PPCz/linuxRemarks
General In-House Tested In-House Tested In-House Tested In-House Tested In-House Tested The test environment uses the 2.6.15-51 (x86-32), 3.2.0-4 (amd64) and 2.6.9-78 (IA64) kernels, and should be downwards compatible. The used libc versions are 2.3.6 (x86-32), 2.13-38 (amd64) and 2.3.4 (IA64).
Ubuntu In-House Tested In-House Tested Expected to run Expected to run Expected to run The Linux x32-bit releases are built on a Ubuntu 6.06 machine with 2.6.15-51 kernel (libc version 2.3.6).
RHEL/CentOS In-House Tested Usage reported In-House Tested In-House Tested Expected to run

IA64 releases are built on a CentOS 4.6 machine with 2.6.9-78 kernel (libc version 2.3.4).

PPC-BE releases are built on RedHat Linux 6.6.

PPC-LE releases are built on RedHat Linux 7.1.

Debian Usage reported In-House Tested Expected to run Expected to run Expected to run The Linux x64-bit releases are built on a Debian 7.2 machine with 3.2.0-4 kernel (libc version 2.13-38).
SuSE Usage reported Usage reported Expected to run Expected to run In-House Tested For the z/linux releases, a SUSE LINUX Enterprise Server 9 (s390x, Patchlevel 4) with a 2.6.5-7.308-s390x kernel is used.

Due to the lack of hardware, we don't provide Linux Wrapper binaries for other architectures (alpha, mips, sparc, etc). However, building the pre-release package should work out of the box. If you need help, please contact us at support@tanukisoftware.com and we will be happy to support you.

AIX

PPCRemarks
AIX In-House Tested The test environment runs on an 32/64 bit multiprocessor kernel version 6.5.

HP-UX

IA64PA-RISCRemarks
10.* Expected to run Expected to run
11.* In-House Tested In-House Tested The test environment runs a 11i (B.11.11) system on a HP9000 Model 785.

FreeBSD

x86x64IA64PPCRemarks
FreeBSD 5 Expected to run Expected to run No No
FreeBSD 6 In-House Tested In-House Tested No No The test as well as the build environments run the 6.4 Release. Basic tests will also be done on a FreeBSD 7 release.
FreeBSD 7 In-House Tested In-House Tested No No Basic tests.
FreeBSD 8 In-House Tested In-House Tested No No

Due to the lack of PowerPC hardware we are currently not providing the Wrapper binaries for this platform. However, building the pre-release package should work out of the box.

Solaris

x86x64SparcRemarks
5.9 In-House Tested Not Applicable In-House Tested The test as well as the build environments runs 5.9 Solaris. This is partly to ensure the Wrapper links correctly to libm.so. Versions below 5.9 are expected (and reported) to run as well.
5.10 In-House Tested In-House Tested In-House Tested
5.11 In-House Tested In-House Tested Expected to run Basic tests only.

MacOSX

x86x64PPCRemarks
MacOSX In-House Tested In-House Tested In-House Tested The binaries for MacOSX are universal binaries and therefore can be used on x86 and PPC architectures as well.

z/OS

z/ArchRemarks
z/OS In-House Tested The test as well as the build environments run on a OS/390 (03.18.00) based system.