World Map
Java Service Wrapper is the easiest way to make your product more reliable.
  • Free Trial
  • Buy Now
Plataformas Compatibles (Wrapper versión 3.5.*)

Índice: Plataformas Compatibles (Wrapper versión 3.5.*)

Descripción

x86x64ARMIA64PPCOtras

No disponible No disponible No disponible No disponible Probado por nosotros No disponible

Probado por nosotros Probado por nosotros No No No No disponible

No disponible No disponible No disponible Probado por nosotros No disponible Probado por nosotrosparisc

Probado por nosotros Probado por nosotros Probado por nosotros Probado por nosotros Probado por nosotros No disponible

Probado por nosotros Probado por nosotros No disponible No disponible Probado por nosotros No disponible

Probado por nosotros Probado por nosotros No No No Probado por nosotrossparc

Probado por nosotros Probado por nosotros Puede funcionar Probado por nosotros No No disponible

No disponible No disponible No disponible No disponible No disponible Probado por nosotros390

Leyenda

  • Probado por nosotros

    Testado internamente. Antes de cada lanzamiento, el Wrapper será testado intensamente para asegurar su funcionalidad.

  • Reportado que funciona

    Uso confirmado por usuarios y colaboradores.

  • Puede funcionar

    Sistema Operativo y APIs compatibles. Espérase que se ejecute normalmente.

  • No

    No soportado

  • No disponible

    No aplicable

Windows

x86x64ARMIA64Nota
Windows Server 2003 Reportado que funciona Reportado que funciona No disponible Probado por nosotros

El Wrapper para Windows Itanium es producido y testado en Windows Server 2003 SP1.

La autenticidad del Wrapper se verificará con el hash SHA-1 de los binarios del Wrapper (SHA-2 no es soportado en esta plataforma).

DEP and ASLR are not supported on this platform.

Windows XP (SP < 3) Reportado que funciona Reportado que funciona No disponible Reportado que funciona

La autenticidad del Wrapper se verificará con el hash SHA-1 de los binarios del Wrapper (SHA-2 no es soportado en Windows XP si el Service Pack 3 no está instalado).

DEP y ASLR no son soportados en esta plataforma.

Windows XP SP3 Probado por nosotros No disponible No disponible No disponible ASLR no es soportado en esta plataforma. DEP está habilitado.
Windows Vista Puede funcionar Puede funcionar No disponible No disponible

DEP y ASLR están habilitados en esta plataforma y todas las versiones de Windows lanzadas después de Windows Vista.

Problema conocido: Devido a una política de seguridad restricta introducida en Windows Vista, los servicios se ejecutan en un escritorio separado. El mismo comportamiento se aplica a todas las versiones de Windows distribuidas después de Windows Vista.

Windows 7 Reportado que funciona Reportado que funciona No disponible No disponible Microsoft publicó una actualización agregando soporte a SHA-2 para esta plataforma. Si la actualización está presente, podrá verificar la autenticidad del Wrapper con el hash SHA-2 incluido en sus binarios. Si no, solamente será posible verificar el hash SHA-1.
Windows Server 2008 Reportado que funciona Reportado que funciona No disponible Reportado que funciona
Windows Server 2008 R2 Probado por nosotros Probado por nosotros No disponible Reportado que funciona

Las versiones actuales de Wrapper para arquitecturas x86 son construidas y testadas en esta plataforma.

Microsoft publicó una actualización agregando soporte a SHA-2 para esta plataforma. Si la actualización está presente, podrá verificar la autenticidad del Wrapper con el hash SHA-2 incluido en sus binarios. Si no, solamente será posible verificar el hash SHA-1.

Windows Server 2012 (& R2) Reportado que funciona Reportado que funciona No disponible No disponible La autenticidad del Wrapper puede ser verificada con los hashs SHA-1 y SHA-2 en esta plataforma y en cualquier versión de Windows lanzada después de Windows Server 2012.
Windows 8/8.1 Reportado que funciona Reportado que funciona No disponible No disponible La autenticidad del Wrapper puede ser verificada con los hashs SHA-1 y SHA-2 en esta plataforma y en cualquier versión de Windows lanzada después de Windows 8.
Windows 10 Probado por nosotros Probado por nosotros Puede funcionar No disponible Windows 10 inició el soporte a arquitecturas ARM64 con a versión 1709. El Wrapper no es especificamente construido para esta arquitectura, pero funcionará a través de emulación. Por favor, póngase en contacto con nosotros si le interesa usar una versión del Wrapper que se ejecuta de forma nativa en Windows ARM.
Windows Server 2016 Probado por nosotros Probado por nosotros No disponible No disponible
Windows Server 2019 Probado por nosotros Probado por nosotros No disponible No disponible
Nano Server No disponible No No disponible No disponible Estamos considerando añadir el soporte a esta plataforma. Si tiene interés, por favor póngase en contacto con nosotros.

Linux

No se conocen restricciones específicas de distribución en el Wrapper para ejecutarse en un sistema operativo basado en Linux.

x86x64ARMIA64PPCz/linuxNota
General Probado por nosotros Probado por nosotros Probado por nosotros Probado por nosotros Probado por nosotros Probado por nosotros El entorno de prueba usa kernels 2.6.15-51 (x86-32), 3.2.0-4 (amd64) y 2.6.9-78 (IA64), y debe tener compatibilidad regresiva. Las versiones de libc usadas son 2.3.6 (x86-32), 2.13-38 (amd64) y 2.3.4 (IA64).
Ubuntu Probado por nosotros Probado por nosotros Probado por nosotros Puede funcionar Puede funcionar Puede funcionar

Las distribuciones Linux x32-bit son desarrolladas en una máquina Ubuntu 6.06 con kernel 2.6.15-51 (libc versión 2.3.6).

La distribución Linux 32-bit ARMHF es dessarrollada en Linaro 12.09 (basado en Ubuntu, libc versión 2.15).

RHEL/CentOS Probado por nosotros Reportado que funciona Puede funcionar Probado por nosotros Probado por nosotros Puede funcionar

Las distribuciones IA64 son desarrolladas en una máquina CentOS 4.6 con kernel 2.6.9-78 (libc versión 2.3.4).

Las distribuciones para PPC-BE se suspendieron en la versión 3.5.42. Las versiones anteriores se desarrollaron en una máquina RedHat Linux 6.7 con kernel 2.6.32 (libc versión 2.12).

Las distribuciones PPC-LE son desarrolladas en una máquina RedHat Linux 7.5 con kernel 4.14.0 (libc versión 2.17).

Debian Reportado que funciona Probado por nosotros Probado por nosotros Puede funcionar Puede funcionar Puede funcionar

Las distribuciones Linux x64-bit son desarrolladas en una máquina Debian 7.2 con kernel 3.2.0-4 (libc versión 2.13-38).

La distribución Linux 32-bit ARMEL es desarrollada en Debian 5 (libc versión 2.11.3).

SuSE Reportado que funciona Reportado que funciona Probado por nosotros Puede funcionar Puede funcionar Probado por nosotros

Para las distribuciones z/linux, se usa SUSE LINUX Enterprise Server 9 (s390x, Patchlevel 4) con un kernel 2.6.5-7.308-s390x.

Linux 64-bit ARM (aarch64) es desarrollada en SUSE Linux Enterprise Server 12 SP4 (libc versión 2.22).

Devido a la falta de hardware, no proveemos binarios del Wrapper para Linux en otras arquitecturas (alpha, mips, sparc, etc). Sin embargo, construir con el paquete de prelanzamiento debe ser posible desde el primer momento. Si necesita ayuda, póngase en contacto con nosotros en support@tanukisoftware.com y con placer le ayudaremos.

AIX

PPCNota
AIX Probado por nosotros El entorno de prueba es ejecutado en un multiprocesador de 32/64 bits y kernel versión 6.5.

HP-UX

IA64PA-RISCNota
10.* Puede funcionar Puede funcionar
11.* Probado por nosotros Probado por nosotros El entorno de prueba ejecuta un 11i (B.11.11) en una HP9000 Model 785.

FreeBSD

x86x64ARMIA64PPCNota
FreeBSD 5 Puede funcionar Puede funcionar No No
FreeBSD 6 Probado por nosotros Probado por nosotros No No Los entornos de prueba y desarrollo se ejecutan en la distribución 6.4. Tests basicos también serán ejecutados en una distribución FreeBSD 7.
FreeBSD 7 Probado por nosotros Probado por nosotros No No Tests básicos.
FreeBSD 8 Probado por nosotros Probado por nosotros No No

Debido a la falta de hardware de PowerPC, actualmente no ofrecemos binarios del Wrapper para esta plataforma. Sin embargo, construir con el paquete de prelanzamiento debe ser posible desde el primer momento.

Solaris

x86x64SparcNota
5.9 Probado por nosotros No disponible Probado por nosotros Los entornos de test y desarrollo usan Solaris 5.9. Esto es parcialmente para asegurar que el Wrapper se vincula correctamente a libm.so. Espérase (y se ha confirmado) que las versiones abajo de 5.9 sean ejecutadas sin problemas.
5.10 Probado por nosotros Probado por nosotros Probado por nosotros
5.11 Probado por nosotros Probado por nosotros Puede funcionar Solamente pruebas básicas.

MacOSX

x86x64PPCNota
MacOSX Probado por nosotros Probado por nosotros Probado por nosotros Los binarios para MacOs son binarios universales y por eso también pueden ser usados en arquiteturas x86 y PPC.

z/OS

z/ArchNota
z/OS Probado por nosotros Los entornos de test y desarrollo son ejecutados en un sistema basado en OS/390 (03.18.00).